CVE-2017-8105

NameCVE-2017-8105
DescriptionFreeType 2 before 2017-03-24 has an out-of-bounds write caused by a heap-based buffer overflow related to the t1_decoder_parse_charstrings function in psaux/t1decode.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-918-1, DSA-3839-1
NVD severityhigh (attack range: remote)
Debian Bugs861220

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freetype (PTS)wheezy2.4.9-1.1+deb7u3vulnerable
wheezy (security)2.4.9-1.1+deb7u7fixed
jessie (security), jessie2.5.2-3+deb8u2fixed
stretch2.6.3-3.2fixed
buster, sid2.8-0.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freetypesource(unstable)2.6.3-3.2high861220
freetypesourcejessie2.5.2-3+deb8u2highDSA-3839-1
freetypesourcewheezy2.4.9-1.1+deb7u6highDLA-918-1

Notes

Fixed by: http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=f958c48ee431bef8d4d466b40c9cb2d4dbcb7791
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=935

Search for package or bug name: Reporting problems