CVE-2017-8311

NameCVE-2017-8311
DescriptionPotential heap based buffer overflow in ParseJSS in VideoLAN VLC before 2.2.5 due to skipping NULL terminator in an input string allows attackers to execute arbitrary code via a crafted subtitles file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3899-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)stretch (security), stretch3.0.11-0+deb9u1fixed
buster, buster (security)3.0.11-0+deb10u1fixed
bullseye, sid3.0.11.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcewheezy(unfixed)end-of-life
vlcsourcejessie2.2.6-1~deb8u1DSA-3899-1
vlcsource(unstable)2.2.5-1

Notes

[wheezy] - vlc <end-of-life> (Not supported in wheezy LTS)
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=775de716add17322f24b476439f903a829446eb6

Search for package or bug name: Reporting problems