CVE-2017-8342

NameCVE-2017-8342
DescriptionRadicale before 1.1.2 and 2.x before 2.0.0rc2 is prone to timing oracles and simple brute-force attacks when using the htpasswd authentication method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-934-1
NVD severitymedium
Debian Bugs861514

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
radicale (PTS)jessie (security), jessie0.9-1+deb8u1vulnerable
stretch1.1.1+20160115-4fixed
buster2.1.11-6fixed
bullseye, sid2.1.11-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
radicalesource(unstable)1.1.1+20160115-4861514
radicalesourcewheezy0.7-1.1+deb7u2DLA-934-1

Notes

[jessie] - radicale <no-dsa> (Minor issue)
https://github.com/Kozea/Radicale/commit/190b1dd795f0c552a4992445a231da760211183b (1.1.x)
https://github.com/Kozea/Radicale/commit/059ba8dec1f22ccbeab837e288b3833a099cee2d (master)

Search for package or bug name: Reporting problems