CVE-2017-8809

NameCVE-2017-8809
Descriptionapi.php in MediaWiki before 1.27.4, 1.28.x before 1.28.3, and 1.29.x before 1.29.2 has a Reflected File Download vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4036-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch (security), stretch1:1.27.7-1~deb9u3fixed
buster, buster (security)1:1.31.6-1~deb10u1fixed
bullseye, sid1:1.31.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.27.4-1
mediawikisourcestretch1:1.27.4-1~deb9u1DSA-4036-1
mediawikisourcewheezy(unfixed)end-of-life

Notes

[wheezy] - mediawiki <end-of-life> (Not supported in wheezy LTS)
https://lists.wikimedia.org/pipermail/mediawiki-announce/2017-November/000216.html
https://phabricator.wikimedia.org/T128209

Search for package or bug name: Reporting problems