CVE-2017-8810

NameCVE-2017-8810
DescriptionMediaWiki before 1.27.4, 1.28.x before 1.28.3, and 1.29.x before 1.29.2, when a private wiki is configured, provides different error messages for failed login attempts depending on whether the username exists, which allows remote attackers to enumerate account names and conduct brute-force attacks via a series of requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4036-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.5-1~deb9u1fixed
stretch (security)1:1.27.7-1~deb9u1fixed
bullseye, sid, buster1:1.31.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.27.4-1medium
mediawikisourcestretch1:1.27.4-1~deb9u1mediumDSA-4036-1
mediawikisourcewheezy(unfixed)end-of-life

Notes

[wheezy] - mediawiki <end-of-life> (Not supported in wheezy LTS)
https://lists.wikimedia.org/pipermail/mediawiki-announce/2017-November/000216.html
https://phabricator.wikimedia.org/T134100

Search for package or bug name: Reporting problems