CVE-2017-8816

NameCVE-2017-8816
DescriptionThe NTLM authentication feature in curl and libcurl before 7.57.0 on 32-bit platforms allows attackers to cause a denial of service (integer overflow and resultant buffer overflow, and application crash) or possibly have unspecified other impact via vectors involving long user and password fields.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4051-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u8fixed
jessie (security)7.38.0-4+deb8u11fixed
stretch7.52.1-5+deb9u4fixed
stretch (security)7.52.1-5+deb9u6fixed
buster, sid7.60.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.57.0-1high
curlsourcejessie7.38.0-4+deb8u8highDSA-4051-1
curlsourcestretch7.52.1-5+deb9u3highDSA-4051-1
curlsourcewheezy(not affected)

Notes

[wheezy] - curl <not-affected> (Vulnerable code not present, introduced in 7.36.0)
https://curl.haxx.se/docs/adv_2017-11e7.html
https://curl.haxx.se/CVE-2017-8816.patch

Search for package or bug name: Reporting problems