CVE-2017-8818

NameCVE-2017-8818
Descriptioncurl and libcurl before 7.57.0 on 32-bit platforms allow attackers to cause a denial of service (out-of-bounds access and application crash) or possibly have unspecified other impact because too little memory is allocated for interfacing to an SSL library.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11fixed
jessie (security)7.38.0-4+deb8u15fixed
stretch (security), stretch7.52.1-5+deb9u9fixed
buster, sid7.64.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.57.0-1high
curlsourcejessie(not affected)
curlsourcestretch(not affected)
curlsourcewheezy(not affected)

Notes

[stretch] - curl <not-affected> (Vulnerable code not present)
[jessie] - curl <not-affected> (Vulnerable code not present)
[wheezy] - curl <not-affected> (Vulnerable code not present)
https://curl.haxx.se/docs/adv_2017-af0a.html
https://curl.haxx.se/CVE-2017-8818.patch

Search for package or bug name: Reporting problems