CVE-2017-8820

NameCVE-2017-8820
DescriptionIn Tor before 0.2.5.16, 0.2.6 through 0.2.8 before 0.2.8.17, 0.2.9 before 0.2.9.14, 0.3.0 before 0.3.0.13, and 0.3.1 before 0.3.1.9, remote attackers can cause a denial of service (NULL pointer dereference and application crash) against directory authorities via a malformed descriptor, aka TROVE-2017-010.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4054-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)bullseye (security), bullseye0.4.5.16-1fixed
bookworm, bookworm (security)0.4.7.16-1fixed
sid, trixie0.4.8.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsourcewheezy(unfixed)end-of-life
torsourcejessie0.2.5.16-1DSA-4054-1
torsourcestretch0.2.9.14-1DSA-4054-1
torsource(unstable)0.3.1.9-1

Notes

[wheezy] - tor <end-of-life> (Not supported in wheezy LTS)
https://bugs.torproject.org/24245
https://blog.torproject.org/new-stable-tor-releases-security-fixes-0319-03013-02914-02817-02516

Search for package or bug name: Reporting problems