CVE-2017-8821

NameCVE-2017-8821
DescriptionIn Tor before 0.2.5.16, 0.2.6 through 0.2.8 before 0.2.8.17, 0.2.9 before 0.2.9.14, 0.3.0 before 0.3.0.13, and 0.3.1 before 0.3.1.9, an attacker can cause a denial of service (application hang) via crafted PEM input that signifies a public key requiring a password, which triggers an attempt by the OpenSSL library to ask the user for the password, aka TROVE-2017-011.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4054-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)jessie (security), jessie0.2.5.16-1fixed
stretch0.2.9.16-1fixed
stretch (security)0.2.9.15-1fixed
buster, sid0.3.4.9-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsource(unstable)0.3.1.9-1medium
torsourcejessie0.2.5.16-1mediumDSA-4054-1
torsourcestretch0.2.9.14-1mediumDSA-4054-1
torsourcewheezy(unfixed)end-of-life

Notes

[wheezy] - tor <end-of-life> (Not supported in wheezy LTS)
https://bugs.torproject.org/24246
https://blog.torproject.org/new-stable-tor-releases-security-fixes-0319-03013-02914-02817-02516

Search for package or bug name: Reporting problems