CVE-2017-8831

NameCVE-2017-8831
DescriptionThe saa7164_bus_get function in drivers/media/pci/saa7164/saa7164-bus.c in the Linux kernel through 4.11.5 allows local users to cause a denial of service (out-of-bounds array access) or possibly have unspecified other impact by changing a certain sequence-number value, aka a "double fetch" vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.89-2vulnerable
jessie (security), jessie3.16.43-2+deb8u2vulnerable
stretch (security), stretch4.9.30-2+deb9u2vulnerable
buster4.11.6-1vulnerable
sid4.11.11-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)(unfixed)high

Notes

https://bugzilla.kernel.org/show_bug.cgi?id=195559

Search for package or bug name: Reporting problems