CVE-2017-8871

NameCVE-2017-8871
DescriptionThe cr_parser_parse_selector_core function in cr-parser.c in libcroco 0.6.12 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted CSS file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs864666

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcroco (PTS)wheezy0.6.6-2fixed
wheezy (security)0.6.6-2+deb7u1fixed
jessie0.6.8-3vulnerable
stretch0.6.11-3vulnerable
buster, sid0.6.12-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrocosource(unstable)(unfixed)low864666
libcrocosourcewheezy(not affected)

Notes

[stretch] - libcroco <no-dsa> (Minor issue)
[jessie] - libcroco <no-dsa> (Minor issue)
[wheezy] - libcroco <not-affected> (Vulnerable code not present)
https://bugzilla.gnome.org/show_bug.cgi?id=782649

Search for package or bug name: Reporting problems