CVE-2017-8903

NameCVE-2017-8903
DescriptionXen through 4.8.x on 64-bit platforms mishandles page tables after an IRET hypercall, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-213.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-964-1, DSA-3847-1
NVD severityhigh (attack range: local)
Debian Bugs861659

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-10fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch (security), stretch4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.1-1+deb9u1high861659
xensourcejessie4.4.1-9+deb8u9highDSA-3847-1
xensourcewheezy4.1.6.lts1-8highDLA-964-1

Notes

https://xenbits.xen.org/xsa/advisory-213.html

Search for package or bug name: Reporting problems