CVE-2017-8905

NameCVE-2017-8905
DescriptionXen through 4.6.x on 64-bit platforms mishandles a failsafe callback, which might allow PV guest OS users to execute arbitrary code on the host OS, aka XSA-215.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-964-1, DSA-3847-1
NVD severitymedium (attack range: local)
Debian Bugs861662

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie (security), jessie4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.3+comet2+shim4.10.0+comet3-1+deb9u5fixed
stretch (security)4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.0~rc3-1medium861662
xensourcejessie4.4.1-9+deb8u9mediumDSA-3847-1
xensourcewheezy4.1.6.lts1-8mediumDLA-964-1

Notes

https://xenbits.xen.org/xsa/advisory-215.html

Search for package or bug name: Reporting problems