CVE-2017-9022

NameCVE-2017-9022
DescriptionThe gmp plugin in strongSwan before 5.5.3 does not properly validate RSA public keys before calling mpz_powm_sec, which allows remote peers to cause a denial of service (floating point exception and process crash) via a crafted certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-973-1, DSA-3866-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)wheezy4.5.2-1.5+deb7u8vulnerable
wheezy (security)4.5.2-1.5+deb7u10fixed
jessie (security), jessie5.2.1-6+deb8u5fixed
stretch (security), stretch5.5.1-4+deb9u1fixed
buster, sid5.6.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.5.1-4medium
strongswansourcejessie5.2.1-6+deb8u3mediumDSA-3866-1
strongswansourcewheezy4.5.2-1.5+deb7u9mediumDLA-973-1

Notes

upstream fix https://git.strongswan.org/?p=strongswan.git;a=commit;h=6681d98d18d24b31410fc12c3d61f150107481b3

Search for package or bug name: Reporting problems