CVE-2017-9066

NameCVE-2017-9066
DescriptionIn WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1075-1
NVD severitymedium (attack range: remote)
Debian Bugs862816

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u16fixed
jessie (security), jessie4.1+dfsg-1+deb8u14vulnerable
stretch4.7.5+dfsg-2fixed
buster, sid4.8.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.7.5+dfsg-1medium862816
wordpresssourcewheezy3.6.1+dfsg-1~deb7u16mediumDLA-1075-1

Notes

https://wordpress.org/news/2017/05/wordpress-4-7-5/
https://github.com/WordPress/WordPress/commit/76d77e927bb4d0f87c7262a50e28d84e01fd2b11

Search for package or bug name: Reporting problems