CVE-2017-9079

NameCVE-2017-9079
DescriptionDropbear before 2017.75 might allow local users to read certain files as root, if the file has the authorized_keys file format with a command= option. This occurs because ~/.ssh/authorized_keys is read with root privileges and symlinks are followed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-948-1, DSA-3859-1
NVD severitymedium (attack range: local)
Debian Bugs862970

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dropbear (PTS)wheezy2012.55-1.3vulnerable
wheezy (security)2012.55-1.3+deb7u2fixed
jessie (security), jessie2014.65-1+deb8u2fixed
stretch2016.74-5fixed
buster, sid2017.75-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dropbearsource(unstable)2016.74-5medium862970
dropbearsourcejessie2014.65-1+deb8u2mediumDSA-3859-1
dropbearsourcewheezy2012.55-1.3+deb7u2mediumDLA-948-1

Notes

Patch: https://secure.ucc.asn.au/hg/dropbear/rev/0d889b068123

Search for package or bug name: Reporting problems