CVE-2017-9083

NameCVE-2017-9083
Descriptionpoppler 0.54.0, as used in Evince and other products, has a NULL pointer dereference in the JPXStream::readUByte function in JPXStream.cc. For example, the perf_test utility will crash (segmentation fault) when parsing an invalid PDF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs863016

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4vulnerable
jessie (security)0.26.5-2+deb8u7vulnerable
stretch (security), stretch0.48.0-2+deb9u2vulnerable
buster, sid0.69.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)(unfixed)unimportant863016

Notes

https://bugs.freedesktop.org/show_bug.cgi?id=101084
Does not use JPX decoder but openjpeg; affected only source wise

Search for package or bug name: Reporting problems