CVE-2017-9144

NameCVE-2017-9144
DescriptionIn ImageMagick 7.0.5-5, a crafted RLE image can trigger a crash because of incorrect EOF handling in coders/rle.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1081-1, DLA-960-1, DSA-3863-1
NVD severitymedium (attack range: remote)
Debian Bugs863126

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-9medium863126
imagemagicksourcejessie8:6.8.9.9-5+deb8u9mediumDSA-3863-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u16mediumDLA-1081-1

Notes

https://github.com/ImageMagick/ImageMagick/commit/7fdf9ea808caa3c81a0eb42656e5fafc59084198

Search for package or bug name: Reporting problems