CVE-2017-9210

NameCVE-2017-9210
Descriptionlibqpdf.a in QPDF 6.0.0 allows remote attackers to cause a denial of service (infinite recursion and stack consumption) via a crafted PDF document, related to unparse functions, aka qpdf-infiniteloop3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs863390

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qpdf (PTS)wheezy2.3.1-4vulnerable
jessie5.1.2-2vulnerable
buster, stretch6.0.0-2vulnerable
sid7.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qpdfsource(unstable)7.0.0-1low863390
qpdfsourceexperimental7.0~b1-1medium

Notes

[stretch] - qpdf <no-dsa> (Minor issue)
[jessie] - qpdf <no-dsa> (Minor issue)
[wheezy] - qpdf <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2017/05/23/10
https://github.com/qpdf/qpdf/issues/101

Search for package or bug name: Reporting problems