CVE-2017-9239

NameCVE-2017-9239
DescriptionAn issue was discovered in Exiv2 0.26. When the data structure of the structure ifd is incorrect, the program assigns pValue_ to 0x0, and the value of pValue() is 0x0. TiffImageEntry::doWriteImage will use the value of pValue() to cause a segmentation fault. To exploit this vulnerability, someone must open a crafted tiff file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-963-1
NVD severitymedium (attack range: remote)
Debian Bugs863410

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)jessie0.24-4.1vulnerable
jessie (security)0.24-4.1+deb8u4vulnerable
stretch (security), stretch0.25-3.1+deb9u1fixed
bullseye, sid, buster0.25-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)0.25-3.1medium863410
exiv2sourcewheezy0.23-1+deb7u1mediumDLA-963-1

Notes

[jessie] - exiv2 <ignored> (Minor issue)
http://dev.exiv2.org/issues/1296
fix: https://github.com/Exiv2/exiv2/commit/2f8681e120d277e418941c4361c83b5028f67fd8

Search for package or bug name: Reporting problems