CVE-2017-9274

NameCVE-2017-9274
DescriptionA shell command injection in the obs-service-source_validator before 0.7 could be used to execute code as the packager when checking RPM SPEC files with specific macro constructs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs887391

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
osc (PTS)jessie0.149.0-2vulnerable
stretch0.156.0-1vulnerable
buster, sid0.162.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
oscsource(unstable)0.162.1-1high887391

Notes

[stretch] - osc <no-dsa> (Minor issue)
[jessie] - osc <no-dsa> (Minor issue)
[wheezy] - osc <no-dsa> (Minor issue)
Details in https://bugzilla.novell.com/show_bug.cgi?id=938556
SUSE adressed the issue not only in the obs-service-source_validator
and adding a validation in 0.162.0 when using OBS 2.9, cf.:
https://github.com/openSUSE/osc/commit/f0325eb0b58c266eb0905ccf827dc7eb864378a1

Search for package or bug name: Reporting problems