CVE-2017-9334

NameCVE-2017-9334
DescriptionAn incorrect "pair?" check in the Scheme "length" procedure results in an unsafe pointer dereference in all CHICKEN Scheme versions prior to 4.13, which allows an attacker to cause a denial of service by passing an improper list to an application that calls "length" on it.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs863884

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chicken (PTS)wheezy4.7.0-1vulnerable
wheezy (security)4.7.0-1+deb7u2vulnerable
jessie4.9.0.1-1vulnerable
stretch4.11.0-1vulnerable
buster, sid4.12.0-0.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chickensource(unstable)4.12.0-0.2low863884

Notes

[stretch] - chicken <no-dsa> (Minor issue)
[jessie] - chicken <no-dsa> (Minor issue)
[wheezy] - chicken <no-dsa> (Minor issue)
Original announcement: http://lists.nongnu.org/archive/html/chicken-announce/2017-05/msg00000.html
Patch: http://lists.nongnu.org/archive/html/chicken-hackers/2017-05/msg00099.html

Search for package or bug name: Reporting problems