CVE-2017-9434

NameCVE-2017-9434
DescriptionCrypto++ (aka cryptopp) through 5.6.5 contains an out-of-bounds read vulnerability in zinflate.cpp in the Inflator filter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs864214

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcrypto++ (PTS)jessie (security), jessie5.6.1-6+deb8u3vulnerable
stretch5.6.4-7fixed
buster, sid5.6.4-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcrypto++source(unstable)5.6.4-7medium864214

Notes

[jessie] - libcrypto++ <no-dsa> (Minor issue)
[wheezy] - libcrypto++ <no-dsa> (Minor issue)
https://github.com/weidai11/cryptopp/issues/414
https://github.com/weidai11/cryptopp/commit/07dbcc3d9644b18e05c1776db2a57fe04d780965

Search for package or bug name: Reporting problems