CVE-2017-9461

NameCVE-2017-9461
Descriptionsmbd in Samba before 4.4.10 and 4.5.x before 4.5.6 has a denial of service vulnerability (fd_open_atomic infinite loop with high CPU usage and memory consumption) due to wrongly handling dangling symlinks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs864291

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie (security), jessie2:4.2.14+dfsg-0+deb8u9vulnerable
stretch2:4.5.12+dfsg-2+deb9u1fixed
stretch (security)2:4.5.12+dfsg-2+deb9u2fixed
buster, sid2:4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.5.6+dfsg-1high864291

Notes

[jessie] - samba <no-dsa> (Minor issue)
[wheezy] - samba <no-dsa> (Minor, non reproducible issue)
https://git.samba.org/?p=samba.git;a=commitdiff;h=10c3e3923022485c720f322ca4f0aca5d7501310
https://bugzilla.samba.org/show_bug.cgi?id=12572

Search for package or bug name: Reporting problems