CVE-2017-9462

NameCVE-2017-9462
DescriptionIn Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a repository name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1005-1
NVD severityhigh (attack range: remote)
Debian Bugs861243

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)wheezy2.2.2-4+deb7u2vulnerable
wheezy (security)2.2.2-4+deb7u5fixed
jessie3.1.2-2+deb8u3vulnerable
jessie (security)3.1.2-2+deb8u4vulnerable
buster, stretch4.0-1vulnerable
stretch (security)4.0-1+deb9u1fixed
sid4.3.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsource(unstable)4.3.1-1high861243
mercurialsourcestretch4.0-1+deb9u1high
mercurialsourcewheezy2.2.2-4+deb7u4highDLA-1005-1

Notes

[jessie] - mercurial <no-dsa> (Minor issue)
https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.1.3_.282017-4-18.29
https://www.mercurial-scm.org/repo/hg/rev/77eaf9539499

Search for package or bug name: Reporting problems