CVE-2017-9465

NameCVE-2017-9465
DescriptionThe yr_arena_write_data function in YARA 3.6.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) or obtain sensitive information from process memory via a crafted file that is mishandled in the yr_re_fast_exec function in libyara/re.c and the _yr_scan_match_callback function in libyara/scan.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs864517

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
yara (PTS)jessie3.1.0-2+deb8u1vulnerable
stretch3.5.0+dfsg-9vulnerable
buster, sid3.8.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
yarasource(unstable)3.6.2+dfsg-1low864517

Notes

[stretch] - yara <ignored> (Minor issue, too intrusive to backport)
[jessie] - yara <ignored> (Minor issue, too intrusive to backport)
https://github.com/VirusTotal/yara/issues/678
https://github.com/VirusTotal/yara/commit/992480c30f75943e9cd6245bb2015c7737f9b661

Search for package or bug name: Reporting problems