CVE-2017-9473

NameCVE-2017-9473
DescriptionIn ytnef 1.9.2, the TNEFFillMapi function in lib/ytnef.c allows remote attackers to cause a denial of service (memory consumption) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs870197

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libytnef (PTS)wheezy1.5-4vulnerable
wheezy (security)1.5-4+deb7u1vulnerable
jessie (security), jessie1.5-6+deb8u1vulnerable
buster, sid, stretch1.9.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libytnefsource(unstable)(unfixed)medium870197

Notes

https://github.com/Yeraze/ytnef/issues/42
https://blogs.gentoo.org/ago/2017/05/24/ytnef-memory-allocation-failure-in-tneffillmapi-ytnef-c/

Search for package or bug name: Reporting problems