CVE-2017-9527

NameCVE-2017-9527
DescriptionThe mark_context_stack function in gc.c in mruby through 1.2.0 allows attackers to cause a denial of service (heap-based use-after-free and application crash) or possibly have unspecified other impact via a crafted .rb file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs865778

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mruby (PTS)jessie1.0.0+20141015+gitb4cc962c-1vulnerable
stretch1.2.0+20161228+git30d5424a-1vulnerable
buster, sid1.3.0-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mrubysource(unstable)(unfixed)low865778
mrubysourceexperimental1.2.0+20170601+git51e0e690-1medium

Notes

[stretch] - mruby <no-dsa> (Minor issue)
[jessie] - mruby <no-dsa> (Minor issue)
https://github.com/mruby/mruby/issues/3486
Fixed by: https://github.com/mruby/mruby/commit/5c114c91d4ff31859fcd84cf8bf349b737b90d99

Search for package or bug name: Reporting problems