CVE-2017-9616

NameCVE-2017-9616
DescriptionIn Wireshark 2.2.7, overly deep mp4 chunks may cause stack exhaustion (uncontrolled recursion) in the dissect_mp4_box function in epan/dissectors/file-mp4.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs870173

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18vulnerable
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7vulnerable
jessie (security), jessie1.12.1+g01b65bf-4+deb8u11vulnerable
stretch2.2.6+g32dac6a-2vulnerable
buster, sid2.4.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.4.0-1low870173

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13777

Search for package or bug name: Reporting problems