CVE-2017-9736

NameCVE-2017-9736
DescriptionSPIP 3.1.x before 3.1.6 and 3.2.x before Beta 3 does not remove shell metacharacters from the host field, allowing a remote attacker to cause remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3890-1
NVD severityhigh (attack range: remote)
Debian Bugs864921

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)wheezy2.1.17-1+deb7u5fixed
wheezy (security)2.1.17-1+deb7u8fixed
jessie3.0.17-2+deb8u3fixed
jessie (security)3.0.17-2+deb8u2fixed
stretch (security), stretch3.1.4-3~deb9u1fixed
buster, sid3.1.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsource(unstable)3.1.4-3high864921
spipsourcejessie(not affected)
spipsourcestretch3.1.4-3~deb9u1highDSA-3890-1
spipsourcewheezy(not affected)

Notes

[jessie] - spip <not-affected> (Vulnerable code not present)
[wheezy] - spip <not-affected> (Vulnerable code not present)
https://contrib.spip.net/CRITICAL-security-update-SPIP-3-1-6-and-SPIP-3-2-Beta
https://core.spip.net/projects/spip/repository/revisions/23593
https://core.spip.net/projects/spip/repository/revisions/23594

Search for package or bug name: Reporting problems