CVE-2017-9779

NameCVE-2017-9779
DescriptionOCaml compiler allows attackers to have unspecified impact via unknown vectors, a similar issue to CVE-2017-9772 "but with much less impact."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)
Debian Bugs874700

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ocaml (PTS)wheezy3.12.1-4vulnerable
wheezy (security)3.12.1-4+deb7u1vulnerable
jessie4.01.0-5vulnerable
stretch4.02.3-9vulnerable
buster4.02.3-10vulnerable
sid4.05.0-9vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ocamlsource(unstable)(unfixed)high874700

Notes

[stretch] - ocaml <no-dsa> (Minor issue)
[jessie] - ocaml <no-dsa> (Minor issue)
https://sympa.inria.fr/sympa/arc/caml-list/2017-06/msg00094.html
https://caml.inria.fr/mantis/view.php?id=7557

Search for package or bug name: Reporting problems