CVE-2017-9780

NameCVE-2017-9780
DescriptionIn Flatpak before 0.8.7, a third-party app repository could include malicious apps that contain files with inappropriate permissions, for example setuid or world-writable. The files are deployed with those permissions, which would let a local attacker run the setuid executable or write to the world-writable location. In the case of the "system helper" component, files deployed as part of the app are owned by root, so in the worst case they could be setuid root.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3895-1
NVD severityhigh
Debian Bugs865413

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flatpak (PTS)stretch0.8.9-0+deb9u3fixed
stretch (security)0.8.9-0+deb9u2fixed
buster, buster (security)1.2.5-0+deb10u4fixed
bullseye1.10.3-0+deb11u1fixed
bullseye (security)1.10.5-0+deb11u1fixed
bookworm, sid1.12.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flatpaksourcestretch0.8.5-2+deb9u1DSA-3895-1
flatpaksource(unstable)0.8.7-1865413

Notes

https://github.com/flatpak/flatpak/issues/845

Search for package or bug name: Reporting problems