CVE-2017-9781

NameCVE-2017-9781
DescriptionA cross site scripting (XSS) vulnerability exists in Check_MK versions 1.4.0x prior to 1.4.0p6, allowing an unauthenticated remote attacker to inject arbitrary HTML or JavaScript via the _username parameter when attempting authentication to webapi.py, which is returned unencoded with content type text/html.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs865497

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
check-mk (PTS)wheezy1.1.12p7-1vulnerable
sid1.2.8p26-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
check-mksource(unstable)(unfixed)medium865497
check-mksourceexperimental1.4.0p9-1medium

Notes

[wheezy] - check-mk <ignored> (Minor issue)
http://mathias-kettner.com/check_mk_werks.php?werk_id=4757
http://git.mathias-kettner.de/git/?p=check_mk.git;a=commitdiff;h=c248f0b6ff7b15ced9f07a3df8a80fad656ea5b1

Search for package or bug name: Reporting problems