CVE-2017-9793

NameCVE-2017-9793
DescriptionThe REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libstruts1.2-javasource(unstable)(unfixed)
libstruts1.2-javasourcewheezy(not affected)

Notes

[wheezy] - libstruts1.2-java <not-affected> (vulnerable code not present)
https://struts.apache.org/docs/s2-051.html

Search for package or bug name: Reporting problems