CVE-2017-9800

NameCVE-2017-9800
DescriptionA maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha3 to run an arbitrary shell command. Such a URL could be generated by a malicious server, by a malicious user committing to a honest server (to attack another user of that server's repositories), or by a proxy server. The vulnerability affects all clients, including those that use file://, http://, and plain (untunneled) svn://.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1052-1, DSA-3932-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10vulnerable
wheezy (security)1.6.17dfsg-4+deb7u12fixed
jessie1.8.10-6+deb8u4vulnerable
jessie (security)1.8.10-6+deb8u5fixed
stretch1.9.5-1vulnerable
stretch (security)1.9.5-1+deb9u1fixed
buster, sid1.9.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.9.7-1
subversionsourcejessie1.8.10-6+deb8u5DSA-3932-1
subversionsourcestretch1.9.5-1+deb9u1DSA-3932-1
subversionsourcewheezy1.6.17dfsg-4+deb7u12DLA-1052-1

Notes

Fixed by: http://svn.apache.org/viewvc?view=revision&sortby=rev&revision=1804691
http://subversion.apache.org/security/CVE-2017-9800-advisory.txt

Search for package or bug name: Reporting problems