CVE-2017-9814

NameCVE-2017-9814
Descriptioncairo-truetype-subset.c in cairo 1.15.6 and earlier allows remote attackers to cause a denial of service (out-of-bounds read) because of mishandling of an unexpected malloc(0) call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs868580

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cairo (PTS)wheezy1.12.2-3vulnerable
wheezy (security)1.12.2-3+deb7u1vulnerable
jessie1.14.0-2.1+deb8u2vulnerable
stretch1.14.8-1vulnerable
buster, sid1.14.10-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cairosource(unstable)(unfixed)low868580

Notes

[stretch] - cairo <no-dsa> (Minor issue)
[jessie] - cairo <no-dsa> (Minor issue)
[wheezy] - cairo <no-dsa> (Minor issue)
https://bugs.freedesktop.org/show_bug.cgi?id=101547

Search for package or bug name: Reporting problems