CVE-2017-9835

NameCVE-2017-9835
DescriptionThe gs_alloc_ref_array function in psi/ialloc.c in Artifex Ghostscript 9.21 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted PostScript document. This is related to a lack of an integer overflow check in base/gsalloc.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1048-1, DSA-3986-1
NVD severitymedium (attack range: remote)
Debian Bugs869907

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2vulnerable
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie9.06~dfsg-2+deb8u5vulnerable
jessie (security)9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.22~dfsg-1medium869907
ghostscriptsourceexperimental9.22~~rc1~dfsg-1medium
ghostscriptsourcejessie9.06~dfsg-2+deb8u6mediumDSA-3986-1
ghostscriptsourcestretch9.20~dfsg-3.2+deb9u1mediumDSA-3986-1
ghostscriptsourcewheezy9.05~dfsg-6.3+deb7u7mediumDLA-1048-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=697985
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=cfde94be1d4286bc47633c6e6eaf4e659bd78066 (ghostpdl-9.22rc1)

Search for package or bug name: Reporting problems