CVE-2017-9868

NameCVE-2017-9868
DescriptionIn Mosquitto through 1.4.12, mosquitto.db (aka the persistence file) is world readable, which allows local users to obtain sensitive MQTT topic information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1146-1
NVD severitylow (attack range: local)
Debian Bugs865959

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mosquitto (PTS)wheezy0.15-2vulnerable
wheezy (security)0.15-2+deb7u2fixed
jessie (security), jessie1.3.4-2+deb8u1vulnerable
buster, sid, stretch1.4.10-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mosquittosource(unstable)(unfixed)low865959
mosquittosourcewheezy0.15-2+deb7u2lowDLA-1146-1

Notes

[stretch] - mosquitto <no-dsa> (Minor issue)
[jessie] - mosquitto <no-dsa> (Minor issue)
https://github.com/eclipse/mosquitto/issues/468
https://github.com/eclipse/mosquitto/commit/09cb1b61c8f48284d9c42bd911faa7525cc689c7

Search for package or bug name: Reporting problems