CVE-2017-9937

NameCVE-2017-9937
DescriptionIn LibTIFF 4.0.8, there is a memory malloc failure in tif_jbig.c. A crafted TIFF document can lead to an abort resulting in a remote denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs869708

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jbigkit (PTS)wheezy, wheezy (security)2.0-2+deb7u1vulnerable
buster, sid, jessie, stretch2.1-3.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jbigkitsource(unstable)(unfixed)medium869708

Notes

http://bugzilla.maptools.org/show_bug.cgi?id=2707
The CVE was assigned for src:tiff by MITRE, but the issue actually lies
in jbigkit itself.

Search for package or bug name: Reporting problems