CVE-2018-0360

NameCVE-2018-0360
DescriptionClamAV before 0.100.1 has an HWP integer overflow with a resultant infinite loop via a crafted Hangul Word Processor file. This is in parsehwp3_paragraph() in libclamav/hwp.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1461-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
clamav (PTS)jessie0.100.0+dfsg-0+deb8u1vulnerable
jessie (security)0.101.4+dfsg-0+deb8u2fixed
stretch0.101.4+dfsg-0+deb9u1fixed
buster0.101.4+dfsg-0+deb10u1fixed
bullseye, sid0.101.4+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
clamavsource(unstable)0.100.1+dfsg-1
clamavsourcejessie0.100.1+dfsg-0+deb8u1DLA-1461-1
clamavsourcestretch0.100.1+dfsg-0+deb9u1

Notes

https://blog.clamav.net/2018/07/clamav-01001-has-been-released.html

Search for package or bug name: Reporting problems