CVE-2018-0488

NameCVE-2018-0488
DescriptionARM mbed TLS before 1.3.22, before 2.1.10, and before 2.7.0, when the truncated HMAC extension and CBC are used, allows remote attackers to execute arbitrary code or cause a denial of service (heap corruption) via a crafted application packet within a TLS or DTLS session.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4138-1, DSA-4147-1
NVD severityhigh (attack range: remote)
Debian Bugs890287

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u3fixed
buster2.13.0-3fixed
sid2.14.1-2fixed
polarssl (PTS)jessie1.3.9-2.1+deb8u3fixed
jessie (security)1.3.9-2.1+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)2.7.0-2high890287
mbedtlssourcestretch2.4.2-1+deb9u2highDSA-4138-1
polarsslsource(unstable)(unfixed)high
polarsslsourcejessie1.3.9-2.1+deb8u3highDSA-4147-1
polarsslsourcewheezy(not affected)

Notes

[wheezy] - polarssl <not-affected> (according to the upstream advisory < 1.2.19 not affected)
https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-01
https://github.com/ARMmbed/mbedtls/commit/992b6872f3ca717282ae367749a47f006d337a87
https://github.com/ARMmbed/mbedtls/commit/464147cadc694379b7717afb7b517fe05cdb323f

Search for package or bug name: Reporting problems