CVE-2018-0618

NameCVE-2018-0618
DescriptionCross-site scripting vulnerability in Mailman 2.1.26 and earlier allows remote authenticated attackers to inject arbitrary web script or HTML via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1442-1, DSA-4246-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mailman (PTS)stretch1:2.1.23-1+deb9u5fixed
stretch (security)1:2.1.23-1+deb9u6fixed
buster, buster (security)1:2.1.29-1+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mailmansourcejessie1:2.1.18-2+deb8u3DLA-1442-1
mailmansourcestretch1:2.1.23-1+deb9u3DSA-4246-1
mailmansource(unstable)1:2.1.27-1

Notes

https://mail.python.org/pipermail/mailman-announce/2018-June/000236.html
https://launchpad.net/mailman/+milestone/2.1.27
https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/revision/1747
https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/revision/1754
https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/revision/1783
https://bazaar.launchpad.net/~mailman-coders/mailman/2.1/revision/1785

Search for package or bug name: Reporting problems