CVE-2018-0733

NameCVE-2018-0733
DescriptionBecause of an implementation bug the PA-RISC CRYPTO_memcmp function is effectively reduced to only comparing the least significant bit of each byte. This allows an attacker to forge messages that would be considered as authenticated in an amount of tries lower than that guaranteed by the security claims of the scheme. The module can only be compiled by the HP-UX assembler, so that only HP-UX PA-RISC targets are affected. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)buster, buster (security)1.1.1n-0+deb10u3fixed
bullseye (security), bullseye1.1.1n-0+deb11u3fixed
bookworm3.0.5-2fixed
sid3.0.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcewheezy(not affected)
opensslsourcejessie(not affected)
opensslsourcestretch1.1.0f-3+deb9u2
opensslsource(unstable)1.1.0h-1unimportant
openssl1.0source(unstable)(not affected)

Notes

[jessie] - openssl <not-affected> (vulnerable code not present)
[wheezy] - openssl <not-affected> (vulnerable code not present)
- openssl1.0 <not-affected> (Only affects OpenSSL 1.1.0)
Issue specific to HP-UX
https://www.openssl.org/news/secadv/20180327.txt

Search for package or bug name: Reporting problems