CVE-2018-1000001

NameCVE-2018-1000001
DescriptionIn glibc 2.26 and earlier there is confusion in the usage of getcwd() by realpath() which can be used to write before the destination buffer leading to a buffer underflow and potential code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)
Debian Bugs887001

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)jessie (security), jessie2.19-18+deb8u10vulnerable
stretch2.24-11+deb9u3vulnerable
stretch (security)2.24-11+deb9u1vulnerable
buster, sid2.27-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)high
glibcsource(unstable)2.26-4high887001

Notes

[stretch] - glibc <postponed> (Minor issue, can be fixed along in next DSA or preferably point release)
[jessie] - glibc <postponed> (Minor issue, can be fixed along in next DSA or preferably point release)
[wheezy] - eglibc <postponed> (Minor issue, can be fixed along in next DSA)
http://www.openwall.com/lists/oss-security/2018/01/11/5
https://sourceware.org/bugzilla/show_bug.cgi?id=22679
https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=52a713fdd0a30e1bd79818e2e3c4ab44ddca1a94

Search for package or bug name: Reporting problems