CVE-2018-1000071

NameCVE-2018-1000071
Descriptionroundcube version 1.3.4 and earlier contains an Insecure Permissions vulnerability in enigma plugin that can result in exfiltration of gpg private key. This attack appear to be exploitable via network connectivity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs897014

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
roundcube (PTS)stretch1.2.3+dfsg.1-4+deb9u2fixed
stretch (security)1.2.3+dfsg.1-4+deb9u3fixed
buster, sid1.3.8+dfsg.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
roundcubesource(unstable)(unfixed)unimportant897014
roundcubesourcestretch1.2.3+dfsg.1-4+deb9u2medium

Notes

https://github.com/roundcube/roundcubemail/issues/6173
https://github.com/roundcube/roundcubemail/commit/48417c5fc9f6eb4b90500c09596606d489c700b5
https://www.legacysecuritygroup.com/cve/references/02122018-roundcube-enigma.txt
That plugin is not functional in stretch due to a missing package dependency, setting it
up would require several additional manual changes on the admin's side
Can be mitigated by moving home folder outside the scope of the webserver

Search for package or bug name: Reporting problems