CVE-2018-1000101

NameCVE-2018-1000101
DescriptionMingw-w64 version 5.0.3 and earlier contains an Improper Null Termination (CWE-170) vulnerability in mingw-w64-crt (libc)->(v)snprintf that can result in The bug may be used to corrupt subsequent string functions. This attack appear to be exploitable via Depending on the usage, worst case: network.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs897196

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mingw-w64 (PTS)jessie3.2.0-2vulnerable
stretch5.0.1-1vulnerable
buster, sid6.0.0-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mingw-w64source(unstable)(unfixed)low897196

Notes

[stretch] - mingw-w64 <ignored> (Minor issue)
[jessie] - mingw-w64 <ignored> (Minor issue)
[wheezy] - mingw-w64 <ignored> (Minor issue)
https://sourceforge.net/p/mingw-w64/bugs/709/

Search for package or bug name: Reporting problems