CVE-2018-1000116

NameCVE-2018-1000116
DescriptionNET-SNMP version 5.7.2 contains a heap corruption vulnerability in the UDP protocol handler that can result in command execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1317-1, DSA-4154-1
NVD severityhigh (attack range: remote)
Debian Bugs894110

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
net-snmp (PTS)jessie5.7.2.1+dfsg-1+deb8u1fixed
jessie (security)5.7.2.1+dfsg-1+deb8u2fixed
stretch (security), stretch5.7.3+dfsg-1.7+deb9u1fixed
bullseye, sid, buster5.7.3+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
net-snmpsource(unstable)5.7.3+dfsg-1.1high894110
net-snmpsourcejessie5.7.2.1+dfsg-1+deb8u1highDSA-4154-1
net-snmpsourcewheezy5.4.3~dfsg-2.8+deb7u2highDLA-1317-1

Notes

https://sourceforge.net/p/net-snmp/bugs/2821/
https://sourceforge.net/p/net-snmp/code/ci/f23bcd3ac6ddee5d0a48f9703007ccc738914791/
Same patch/commit as #788964 (as used for fixing CVE-2015-5621)
adresses CVE-2018-1000116 as well.

Search for package or bug name: Reporting problems