Descriptionnghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs895566

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nghttp2 (PTS)stretch1.18.1-1+deb9u1vulnerable
stretch (security)1.18.1-1+deb9u2fixed
buster, buster (security)1.36.0-2+deb10u1fixed
bookworm, sid, bullseye1.43.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nghttp2sourcejessie(not affected)


[jessie] - nghttp2 <not-affected> (Issue introduced in 1.10.0)
Affected versions: nghttp2 >= 1.10.0 and nghttp2 <= v1.31.0
Fixed by:

Search for package or bug name: Reporting problems