CVE-2018-1000222

NameCVE-2018-1000222
DescriptionLibgd version 2.2.5 contains a Double Free Vulnerability vulnerability in gdImageBmpPtr Function that can result in Remote Code Execution . This attack appear to be exploitable via Specially Crafted Jpeg Image can trigger double free. This vulnerability appears to have been fixed in after commit ac16bdf2d41724b5a65255d4c28fb0ec46bc42f5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1651-1
NVD severitymedium
Debian Bugs906886

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)jessie2.1.0-5+deb8u11vulnerable
jessie (security)2.1.0-5+deb8u13fixed
stretch2.2.4-2+deb9u5fixed
stretch (security)2.2.4-2+deb9u4fixed
bullseye, sid, buster2.2.5-5.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.5-4.1low906886
libgd2sourcejessie2.1.0-5+deb8u12DLA-1651-1
libgd2sourcestretch2.2.4-2+deb9u3

Notes

https://github.com/libgd/libgd/issues/447
https://github.com/libgd/libgd/commit/ac16bdf2d41724b5a65255d4c28fb0ec46bc42f5

Search for package or bug name: Reporting problems