CVE-2018-1000300

NameCVE-2018-1000300
Descriptioncurl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10fixed
stretch (security)7.52.1-5+deb9u12fixed
buster, buster (security)7.64.0-4+deb10u1fixed
bullseye, sid7.72.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy(not affected)
curlsourcejessie(not affected)
curlsourcestretch(not affected)
curlsource(unstable)7.60.0-1

Notes

[stretch] - curl <not-affected> (Vulnerable code introduced in 7.54.1)
[jessie] - curl <not-affected> (Vulnerable code introduced in 7.54.1)
[wheezy] - curl <not-affected> (Vulnerable code introduced in 7.54.1)
https://curl.haxx.se/docs/adv_2018-82c2.html

Search for package or bug name: Reporting problems